Health & Safety
International / unresolved · Direct U.S. connection
Critical PHP Vulnerabilities Led to Widespread Exploitation Attempts Before Patch Release
Two critical remote code execution vulnerabilities in PHP, dubbed PHP2Shell, were patched on October 21, 2026, after details leaked online and exploitation attempts began four days prior, affecting approximately 70% of websites globally.
Share this article
THE PRIMARY BRIEF
- 01 · The primary finding
Two critical remote code execution vulnerabilities in PHP, dubbed PHP2Shell, were exploited days before their public disclosure and patch release on October 21, 2026, affecting a significant portion of global websites.
- 02 · The primary evidence
CVE-2026-109618 and CVE-2026-109619, rated 9.2 Critical, allowed unauthenticated attackers to execute arbitrary code due to memory safety flaws that existed for over a decade.
- 03 · Why it matters
With PHP powering approximately 70% of websites, including major CMS platforms, the incident triggered widespread emergency patching and highlighted the vulnerabilities inherent in foundational web technologies and the accelerating pace of AI-driven threat discovery.
Two critical remote code execution vulnerabilities, collectively known as PHP2Shell, were patched on October 21, 2026, after details leaked online and exploitation attempts began four days prior. These flaws affected approximately 70% of websites globally, allowing unauthenticated attackers to execute arbitrary code on servers.
The widespread use of PHP in popular content management systems like WordPress, Drupal, and Joomla meant that these vulnerabilities posed a significant risk to a vast portion of the internet's infrastructure. The rapid public disclosure and subsequent exploitation created an urgent situation for website administrators worldwide, highlighting the fragile security of foundational web technologies.
What the records show
The two critical memory-corruption RCE vulnerabilities are tracked as CVE-2026-109618 and CVE-2026-109619. Both were assigned a critical CVSS 4.0 score of 9.2. CVE-2026-109618 stems from out-of-memory errors where PHP’s longjmp() function leaves request memory uninitialized, allowing RCE. CVE-2026-109619 relates to PHP's global state potentially referencing freed memory regions following abnormal request termination. These memory safety flaws are reported to have existed in the PHP codebase for over a decade, with all PHP versions from 5.4 through 8.5.11 identified as vulnerable, including older unsupported branches like PHP 5. Cybersecurity firm Calif, along with OpenAI, contributed to the discovery efforts using a frontier model from OpenAI. Initial signs of these vulnerabilities were noted by researchers during a security audit in 2024, but their exploitability could not be proven at that time.
The timeline
Amazon Threat Intelligence detected the first exploitation attempt for PHP2Shell on October 17, 2026, four days before the public disclosure. This attempt originated from an anonymized IP address targeting a honeypot, suggesting the activity was carried out by a threat actor. On October 20, 2026, details of the vulnerabilities leaked online, appearing on social media and online forums. This leak prompted the PHP security team to accelerate their patch release schedule, bringing it forward by a day. Following the leak and before the official patch, proof-of-concept exploits began to circulate, leading to an increase in exploitation attempts. Official patches for versions 8.5.12, 8.4.27, 8.3.36, and 8.2.35 were released on October 21, 2026, at 14:00 UTC.
What changed and for whom
The incident led to extensive impact across the internet due to PHP’s widespread adoption by approximately 70% of websites globally. Popular content management systems such as WordPress, Drupal, and Joomla were specifically identified as being affected. As a precautionary measure, government websites in Germany and Finland, among other European countries, were temporarily taken offline. Sites like 4chan reportedly experienced outages. The U.S. Cybersecurity and Infrastructure Security Agency (CISA) issued a strong advisory urging immediate patching for CVE-2026-109618 and CVE-2026-109619 to the latest patched versions. The PHP project is not releasing fixes for PHP 8.1 or earlier versions, as they have reached end-of-life status, requiring users of these older versions to migrate to a supported branch. Volunteer maintainer Ondřej Surý, who helps automate patches for PHP, played a key role in the rapid response efforts, building update packages used by administrators worldwide.
What the subject has said publicly
Cloudflare CEO Matthew Prince stated that in the 10 hours before the flaws were publicly announced, Cloudflare observed thousands of exploitation attempts. He added that these attempts jumped to tens of thousands within 45 minutes of the announcement, hundreds of thousands within two hours, and millions afterward. CISA strongly urged organizations to immediately update to PHP 8.5.12, 8.4.27, 8.3.36, or 8.2.35 to fix these vulnerabilities. Amazon reported that the initial exploitation attempt from an anonymized IP address before disclosure suggests threat actor activity.
What we could not confirm
It remains unclear how the actor who made the initial exploitation attempt on October 17, 2026, acquired exploit information prior to the public disclosure.
SHOW YOUR WORK